Power Equipment Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey all, this is my first post so any help would be much appreciated!

I have recently purchased a second hand XRS25 air compressor off somebody and have just discovered that it seems to have some major issues.
It makes a Horrible rattling noise from inside the compressor pump when you first start it up and continues to do that until it gets to about 15-20 psi and then calms down and continues to run a bit quieter.
The second issue is that I’ve done some tests and worked out that it’s only producing about 8CFM instead of the advertised 18 which I assume is linked with that horrible noise?

I was thinking of just pulling the compressor pump apart and seeing if there was an issue with one of the pistons maybe? But figured I’d ask the experts first.

Thanks in advance, Tom
 

·
Registered
Joined
·
142 Posts
Hi TommyB,

To obtain a first approach. you may do the following test:

1.- Unplug the compressor
2.- Remove the pulley protector
3.- remove the air filters
4.- Cover with a hand one air inlet
5.- Re confirm that the compressor is disconnected
6.- Turn by hand the pump pulley
7.- Check if the piston produces and maintains vaccum
8.- Repeat with the other cylinder.

With respect to the second issue, it seems that only one cylinder is working. In this ad:

https://www.toolmart.com.au/sp-xrs25.html

I have seen that the FAD ( free air delivery) is 428 Liters per minute. As a cubic foot is equivalent to 28.3168 liters (30.48cm x 30.48cm x 30.48cm= 28,316.8 cm3= 28.3 Lt), 428 liters are aprox 15.1 cubic feet. Half of this volume is 7.5 CF, near to your calculations.
This is only an approch, please wait for an expert and more complete opinion in this forum.

Regards.
 

·
Registered
Joined
·
112 Posts
TommyB

Osviur gave some good advice, sounds like you have a broken/leaking read valve or a piston bore issue. I would remove the head on the suspected cylinder and take a look, you can tell a lot by doing that. Are there metal particles in the oil?

Stephen
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Thank you both for your replies 🙏 I did what you suggested and checked the suction at the air filter and found one of them was lacking so I’ve filled that one apart and found that one of the reed valves had exploded into pieces it seems 🙄 so I’ve got all those out and now just to replace that and the gasket that was pretty raggedy and see how we go 👍👍

Thanks again Osviur and Stephen
 
1 - 4 of 4 Posts
Top