Power Equipment Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi, my generator cut out on me today and turns out the oil was low so I changed it completely. I haven't been able to restart it since. Its a ryobi inverter 2300
Vehicle Car Technology Electronics City car
Vehicle Car Technology Auto part Electronic device

  1. The oil level is good
  2. There is fuel
  3. I regularly use seafoam to keep the carb clean
  4. I've had no issues with it before and has run well
  5. When I was searching for what the issue was I found a small plastic tube that wasn't connected to anything, no idea if that's the issue
  6. I know very little about mechanics
  7. I live off grid and desperately need this up and running, who has the cash to buy a new one right now with everything going on
If anyone could tell me what that tube is and if/what its meant to connect to and if that's my issue I would be very grateful. Pictures included and thanks in advance for your help
 

·
Registered
Joined
·
212 Posts
You might want to re-post this in the Generator Forum.
My only guess on this is that there might be some sort of reset. Usually, though, the ground that is applied to the ignition (when the low oil switch is activated) is removed with the addition of oil.
Good luck.
 

·
Registered
Joined
·
16 Posts
Try disconnecting the wire to the low oil sensor and then attempt to start it. If it runs then reconnect the low oil sensor wire. If that causes it to quit then you'll need a new sensor. Check your oil level more frequently to avoid the low oil shutdown. Bearings usually wear excessively during low oil conditions reducing engine life.
 
1 - 4 of 4 Posts
Top