Power Equipment Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
I've not posted lots on PEF but have greatly benefited from the knowledge shared here. Great forums. On to my issue...I've have a HF Predator 3500 whose display won't show anything but hours. Somebody else posted with this issue, but I don't see they ever figured out a solution. I pulled the panel and all seems to be hooked up fine. Maybe a wire loose on the generation side of things? For voltage, current etc., it just shows zero. Generator works fine, just can't see the voltage it's putting out or the load. Any thoughts? Ways to test the screen? Thanks for any ideas. I would love to fix this before we have some Public Safety Power Shut downs. Thank you in advance for any ideas.
 

·
Registered
Joined
·
1,204 Posts
replace the display unit assy is the solution.
they are not a good item...
bad vender issue on the display.
hf has the parts.
ring them for prices..
the good news is the display does not affect the run on the gen set.
at least on this model.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #3
I appreciate the information. I would purchase a new one, but, unfortunately, I can't find the part number. It doesn't appear to be available. If you can provide me with a part number I would be most appreciative.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #5 (Edited)
Again, I appreciate the response. I'll try emailing them. Very difficult to tell what part number the screen portion really is. Sure wish they did a better job listing the part descriptions. They are not taking calls either. Will post their response.
 

·
Premium Member
Joined
·
350 Posts
Most of these chinese gens are almost identical but each brand iteration carries parts differances. I wonder if the equivalent PowerHorse inverter generators from northern tool cast a different light on parts availability.
 

·
Registered
Joined
·
1,204 Posts
Again, I appreciate the response. I'll try emailing them. Very difficult to tell what part number the screen portion really is. Sure wish they did a better job listing the part descriptions. They are not taking calls either. Will post their response.
ahh HF parts might be still on lock down..
they might be just doing the q and a via computer..

so Mendoteach are you needing to see the power output and an hour meter?
how are you using the generator for home power backup , construction or rv use?
they have basic rpm, tach meters for low cost.
and for home use they have meters you can place on your generator inlet or the inlet at the home breaker panel
click here for the generator inlet meter page pix and parts lists
on that page I have pix of what I did for meters at the breaker panel.
 

·
Registered
Joined
·
1,204 Posts
Thanks! I like that link.
there is also a modification you can make on that setup for L1 and L2 input meters for a 240 volt generator.
different larger grey meter box and a second meter.

the meter set up lets you see;
2) L1 and L2 grid led indicators to let you know if there is power on the main breaker input side even if the main breaker is switched off..
there are 1/4 amp inline fuses for safety.

2) switches to indicate L1 (black) L2 (red) that control the meter display for the 2) 200 amp grid meters.

there is also one led as well as one black switch for the generator input meter.
the led lets you know there is power on the generator input at a glance.

the generator meter is a 100 amp 6 line meter volts, amps, watts, hz, watt/hour power, factor.

it is a basic information meter setup.
 

·
Registered
Joined
·
1 Posts
I've not posted lots on PEF but have greatly benefited from the knowledge shared here. Great forums. On to my issue...I've have a HF Predator 3500 whose display won't show anything but hours. Somebody else posted with this issue, but I don't see they ever figured out a solution. I pulled the panel and all seems to be hooked up fine. Maybe a wire loose on the generation side of things? For voltage, current etc., it just shows zero. Generator works fine, just can't see the voltage it's putting out or the load. Any thoughts? Ways to test the screen? Thanks for any ideas. I would love to fix this before we have some Public Safety Power Shut downs. Thank you in advance for any ideas.
I have the same problem with my 3500, purchased it on 5/14/2020. Work great through all the break in periods. Started it up for the 3 month run and all I get on the display is the hours run time and time of present run. Emailed the company but have not received a reply on this issue.
 
1 - 11 of 11 Posts
Top