Power Equipment Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I am wondering if anyone could point me into the right direction to troubleshoot this generator.
Engine runs great. No output.

I have pulled the generator cover and the windings are clear with no burnt wires. It looks like
the previous owner may have changed the board. The part number on the board is

B05858-A2LF

And it looks new. I believe the original board was a G89769-B1, but I'm certain.

What I'm first interested in is how to check the coil windings for opens... which colors etc.

The inside of the Generator looks pretty clean. The whole unit looks like it's had normal use,
whatever that is.

Wiring diagram, troubleshooting steps, anything which would help. If the board is the correct one would help.

Thanks much

7905
7906
7907
7908
 

·
Registered
Joined
·
2 Posts
Discussion Starter #6
Thank you for your comments all...

I didn't hear from anyone on this post so I decided to do the best I knew how. I found the commentator wires to have low resistance and thought, they are good. The other two leads coming to the AVR from the Generator when checked had no resistance at all. So I figured there must be an open connection somewhere within. So, figuring I've got nothing to lose, I pulled the stator. After much inspection, I found an area on the outside coil turns where something had rubbed on a few wires. One was cracked. When I jumped the break with alligator clips, the continuity was back on the leads.

I'm in the process of repairing the broken wire and a couple next to where it broke. I'm thinking I will get this thing back running again.

I appreciate you all jumping in.
 
1 - 7 of 7 Posts
Top