Power Equipment Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi. The short youtube video clip at the link here shows the problem Im having.
My 240v generator starts first pull, runs with choke closed but stalls as soon as I move the choke to the normal running position. Any ideas? More detail about the unit in my short vid clip. Thanks for your time.. Cheers...Regards Woodlock.
 

·
Registered
Joined
·
123 Posts
1. Was the gen stored with fuel in it? If so treated or untreated fuel? Was there gum or varnish causing the crab’s needle to stick?

2. If it was stored 5 yrs with or w/o treated fuel and the carb is sealed on good, I feel you need to Soak the carb in cleaner at least 8 hrs with all needles and etc out of the carb. Run small wire through all port holes or Compressed air or cleaner to verify all ports are open. Count your needle’s turn to lightly to seat to have a ref to reinstall needles.


3. You might try spraying WD-40 or carb cleaner on any suspected leaks as the Gen is stopping to see if a leak is sniffed out.

4. The theory is, with the choke closed is causing it to pull fuel due to lack of sealing or fuel restriction IMO.
 

·
Registered
Joined
·
123 Posts
Oops! I try to start/store all of my unused tools yearly with a fresh batch of Stabil treated fuel in a topped tank to avoid moisture. OR! Run it Bone Dry until every drop is burned or drained. This has worked good since the 60s w/o any problems Except For Work!
 

·
Premium Member
Joined
·
611 Posts
I agree with jow pull the carb and soak it in solvent then make sure to clean all passages you'll have to look closely for tiny passages
 
1 - 4 of 4 Posts
Top