Power Equipment Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I recently bought a powerstroke 3500 watt 212cc generator from a guy who sold it to me for $40. He said the only problem was the carb needed to be cleaned out, than it would start and run. I got back home and tore the carb apart it was full of rust and gunk so I cleaned it. I also did an oil change which uncovered what seemed to be mud in the Bottom of the crank case. So I cleaned it out and put fresh oil in. I put the carb back on after cleaning it and tried cranking it with new gas and filter. Nothing happend so I sprayed some carb cleaner into the inlet and still, nothing happened until about 8 pulls. I got a backfire from the exhaust but that was it. I’ve tried everything to get it running but can’t. I checked the compression and it was only at +/- 37 psi. I know that’s low.... I check the valves which seem to look ok. I took the head off and shined a light onto the inlet and I could see a tiny crack of light coming from the valve. So I kept trying to get it started but still no luck. I changed the gas in the tank again and hooked the carb back up. Than I pulled and I got a back fire from the carb with a cloud of white smoke. I sprayed some WD40 into the carb and it looked like it was blowing the WD40 back at me. It also seems to have a lot of air coming out of the breather tube (I don’t know if it’s normal) At this point I am lost and aggravated I don’t know what else could be wrong and I don’t want to spend $100 just for someone to look at it. Does anyone know what the problem might be?
 
1 - 2 of 2 Posts
Top