Power Equipment Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Good day, wonder if anyone can assist. I'm currently busy with a screw compressor as mentioned above. I replaced the drive belt as the previous one snapped. The original belt is a 1480PK12 but this is only locally available through the agents who wants to charge way to much for the item. I changed the belt to a 1460PK12 which fits as it's a self tension udjusting unit as far as I can understand. This unit was manufactured in the year 2000 so the control panel has no way of identifying exact error codes. Only a red warning light that can't be canceled and in turn does not allow me to restart the unit without bypassing the control panel and working with the contactors only.

Here is the issue. Upon starting the unit after belt was replaced the unit started to load and then tripped the electrical circuit at the D.B board. I started with a process of elimination and discovered that the oil return pipe that's on top of the oil separator unit is clogged.

1st. Would that clogged pipe cause the unit to build up pressure in the oil separator tank and not opening the discharge valve on top of the tank?

2nd. How does one determine the error as there is no lcd screen like the newer models?

3rd. How do you reset this error so I can start the unit at the control panel when I'm finished cleaning and unclogging everything?

Regards
Francois
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
That's my next move is to sweep through the unit from start to finish. No manual at all on the unit and google does not seem to have anything for that year model either.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
I.R Here in South Africa has the worst aftersales service ever. So yes would be my last redort.
 
1 - 6 of 6 Posts
Top