Power Equipment Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi

My Honda EU6500is is giving me a headache! It came with a truck i bought wtih 600hours on the clock. I assume it is well maintainced since the truck came from Team Honda Dakar.
It had not been used in a while, so did a gaschange, oilchange, spark plug, filter, cleaned the carb. etc.
It would start right away, but start surging after a minute or two and then die. Showed Error 06.
Guessed it was the inverter, but handed it to a mechanic, he said the same thing - inverter burned off.
Got a new inverter, and after installation it dies as soon as i let go of the key, but the starter engine sounds normal and it sounds normal in the engine. Of course i don't want to continue cranking the starter, but it sounds healthy, but when i release it just dies instantly.
Carb looks good, gasflow, spark is normal.
What to do, any ideas? Still comes up with same error. Should it be able to run without inverter installed so I can test if thats the problem?

Thanks
Michael
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Carburetor has been cleaned and fresh fuel. Before changing inverter it could run for maybe a minute or two. Starting fluid no good, it dies instantly when i release the starter engine
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #7 ·
Thx. I'll see if I can find a place with a cleaner and give it a go. And then try the testing steps from the manual. After some digging around i manged to find the shop manual for the 6500.

But do any of you guys know if it should be possible to run the engine without the inverter connected?
 
1 - 3 of 3 Posts
Top