Power Equipment Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a honda 7000 and the unit runs fine but will not start witth the electric start . . you have to pull start it. battery is brand new. when i turn the key on the i monitor lights come on as normal but when you hit the start switch nothing happens. it is also hooked up to a remote start kit and same thing happpens there but it will shut it off. any help be greatley appreciated
 

·
Registered
Joined
·
476 Posts
How new is new? Is the battery a replacement? If so, was it recommended by a Honda dealer? Have you called them about the issue? Has it been charged prior to use? Did the electric start ever work right? …. We need a little more info ….
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
the inverter is about 5 years old and has worked flawlessly. never had trouble with starting before. . battery is a interstate cranking battery putt ing out 13.4 volts.. started having trouble last fall with it intermittenly cranking . so this spring cant get it to crank at all
 

·
Registered
Joined
·
476 Posts
13.4 volts sounds like you checked it right after you removed the charger. It needs to sit for a day before checking the voltage. Well I’d have the battery load tested. It should really be kept on a battery maintainer to prolong its life… Keep us posted how the battery tests out.
 

·
Registered
Joined
·
435 Posts
Run jumper cables from a car battery to your Honda battery terminals and see if it starts. If so, then your Honda battery is no good. Get a trickle charger/battery maintainer to keep the battery healthy. I use this one for my Honda:

 
1 - 6 of 6 Posts
Top