Power Equipment Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
My 2000i is almost 20 years old and has been a stellar item at my off-grid cabin. However, I just upgraded my inverter/charger from one that charged at 55 amps to one that is now charging at up to 85 amps ( and 24v system vs 12v system if that matters ). the newer system shows a draw of 1.6KW from the generator. However, my old honda which charged the old system well...not cuts off after being connected to new one after a couple of minutes run time...revs drop but still runs so the "draw" is gone as it is on eco-throttle. I am wondering if this is an indicator that the inverter feature is failing ? It will still run skill saws etc but cant seem to handle this draw.
Using my neighbours newer 2000i, it doesnt drop off and continues to charge just fine..so i know its not the Inverter/Charger.
Interested in folks thoughts on what is causing this and $'s to remedy ? Thanks. .
 

·
Registered
Joined
·
226 Posts
Well, your 20 year old Honda is certainly tired.... but if you’re drawing 1600 watts then you’re pulling the maximum continuous wattage. The age and hours on the unit also play a factor. A new Honda 2200i would provide ample wattage. However short life is a side effect of running a generator near it’s continuous maximum... I’d recommend a Honda 3000 inverter and sell the 2000. You might be surprised at what you might get for it. Dutchy
 

·
Registered
Joined
·
3,815 Posts
My 2000i is almost 20 years old and has been a stellar item at my off-grid cabin. However, I just upgraded my inverter/charger from one that charged at 55 amps to one that is now charging at up to 85 amps ( and 24v system vs 12v system if that matters ). the newer system shows a draw of 1.6KW from the generator. However, my old honda which charged the old system well...not cuts off after being connected to new one after a couple of minutes run time...revs drop but still runs so the "draw" is gone as it is on eco-throttle. I am wondering if this is an indicator that the inverter feature is failing ? It will still run skill saws etc but cant seem to handle this draw.
Using my neighbours newer 2000i, it doesnt drop off and continues to charge just fine..so i know its not the Inverter/Charger.
Interested in folks thoughts on what is causing this and $'s to remedy ? Thanks. .
well...
it is a fine line on load and efficiency.

you need a larger gen set to run the larger load..
but that is more fuel.
i agree a 3000i is a better choice.
or add another eu2200i gen set in parallel.

or down size the charger to the same voltage out but a bit less on the current demand.
or check to see if there is a setting on the charger for a lower charge rate when on gen set.
some have dip switches to set the charge rates...

pm if you need help with the parallel!
 

·
Registered
Joined
·
3,815 Posts
My 2000i is almost 20 years old and has been a stellar item at my off-grid cabin. However, I just upgraded my inverter/charger from one that charged at 55 amps to one that is now charging at up to 85 amps ( and 24v system vs 12v system if that matters ). the newer system shows a draw of 1.6KW from the generator. However, my old honda which charged the old system well...not cuts off after being connected to new one after a couple of minutes run time...revs drop but still runs so the "draw" is gone as it is on eco-throttle. I am wondering if this is an indicator that the inverter feature is failing ? It will still run skill saws etc but cant seem to handle this draw.
Using my neighbours newer 2000i, it doesnt drop off and continues to charge just fine..so i know its not the Inverter/Charger.
Interested in folks thoughts on what is causing this and $'s to remedy ? Thanks. .
the stator could be getting hot spots.
it is time to check the windings for sure...
and yes at hard rated loads for hours on end will "cook" a good stator as well as the inverter.

a proper load would be 1200 watts or less on a eu2000i gen set.

a proper gen with the new system load you have now would be an eu3000i gen set.
or run 2 of the eu2200i gens in parallel.
 
1 - 5 of 5 Posts
Top