Power Equipment Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I’m having an issue with the generator in my RV. I’ve tried getting some help in a few RV forums with no success. So hopefully someone here may be able to steer me in the right direction.
The generator starts and runs perfectly. However it will produce power for 11 seconds then no power for 1:22 then power for 11 seconds and then no power for 1:22. Over and over.
I’m thinking perhaps it’s the voltage regulator. Thoughts?
All of the trouble shooting flow charts deal with units that don’t produce any power and this one cycles. I’m was just wondering if anyone had any insight before I begin buying parts.
Thank you
 

·
Registered
Joined
·
143 Posts
Hi,

I was loocking at this PDF: soa.generac.com/manuals/362930/G098773, and found in the wiring diagram a circuit breaker named CB3. It protects the rotor winding from oveloads (maybe from a failing AVR), cutting AC power comming from the stator's excitation winding to feed the AVR. This CB may be an auto reset type that is tripping due to an internal failure or due to a real overload caused by an AVR failure or a rotor winding low resistance condition. The first condition is more probable than the others, specially if
in the 11 seconds period the delivered power is correct. Locating and testing this CB may be some difficult.

Good luck!
 

Attachments

·
Registered
Joined
·
292 Posts
When it supplies power, are you actually running a load? Or does it just show voltage?

If you're not running a load, maybe try actually running a moderate device. Several hundred watts, etc. And see if that different load changes the 11 seconds to something shorter. It might at least just give some other symptoms, to help understand the behavior.
 
1 - 4 of 4 Posts
Top