Power Equipment Forum banner
61 - 80 of 82 Posts

·
Registered
Joined
·
9 Posts
yea take it back to costco!
I called Firman and they knew exactly what it was after I described it. Said if the digital display was working, it was the VFO. If not, it was the AVR. It was not working so they sent me a new AVR. I replaced and it is working like a charm now, but I notice the volts on the display now run around 232-235 instead of the 244-245 it displayed previously. Anyone know if this is due to the new AVR or if it will affect load performance?
 

·
Registered
Joined
·
4,423 Posts
I called Firman and they knew exactly what it was after I described it. Said if the digital display was working, it was the VFO. If not, it was the AVR. It was not working so they sent me a new AVR. I replaced and it is working like a charm now, but I notice the volts on the display now run around 232-235 instead of the 244-245 it displayed previously. Anyone know if this is due to the new AVR or if it will affect load performance?
adjust the voltage with the speed controller.
set to 60 hz with a 1500 watt load
 

·
Registered
Joined
·
3 Posts
Yep, in 2018 as it looks like everyone with same problem did too. Just wondering if anyone found the magic fix. I did disconnect the VFO as mentioned prior and it stayed running.
In my case (Costco 2018 / Blinking Red Light), the initial troubleshooting pointed to the AVR (gen kept running when I disconnected the wires as directed by Firman). However, after removing the round side cover of the generator to get at the AVR (2 hex head bolts) I noticed the brush holder was broken, prompting an even closer look inside. That was when I noticed one of the two rings at the end of the rotor shaft (where the brushes are supposed to rest) was bent up - you really have to look closely with a light to see it, and rotate the shaft to see all sides. Once I passed this information along to the Firman customer service people, they sent me a new unit, which I received yesterday. My unit was still in warranty by about two weeks, had it not been and Firman refused to repair/replace, I probably would have returned it to Costco and let them handle it, BUT it was still under warranty and replaced without any question at all.
 

·
Registered
Joined
·
9 Posts
In my case (Costco 2018 / Blinking Red Light), the initial troubleshooting pointed to the AVR (gen kept running when I disconnected the wires as directed by Firman). However, after removing the round side cover of the generator to get at the AVR (2 hex head bolts) I noticed the brush holder was broken, prompting an even closer look inside. That was when I noticed one of the two rings at the end of the rotor shaft (where the brushes are supposed to rest) was bent up - you really have to look closely with a light to see it, and rotate the shaft to see all sides. Once I passed this information along to the Firman customer service people, they sent me a new unit, which I received yesterday. My unit was still in warranty by about two weeks, had it not been and Firman refused to repair/replace, I probably would have returned it to Costco and let them handle it, BUT it was still under warranty and replaced without any question at all.
thanks. Might need to take mine back off and take a look at the rings just in case. My warranty expires in a month.
 

·
Registered
Joined
·
4,423 Posts
In my case (Costco 2018 / Blinking Red Light), the initial troubleshooting pointed to the AVR (gen kept running when I disconnected the wires as directed by Firman). However, after removing the round side cover of the generator to get at the AVR (2 hex head bolts) I noticed the brush holder was broken, prompting an even closer look inside. That was when I noticed one of the two rings at the end of the rotor shaft (where the brushes are supposed to rest) was bent up - you really have to look closely with a light to see it, and rotate the shaft to see all sides. Once I passed this information along to the Firman customer service people, they sent me a new unit, which I received yesterday. My unit was still in warranty by about two weeks, had it not been and Firman refused to repair/replace, I probably would have returned it to Costco and let them handle it, BUT it was still under warranty and replaced without any question at all.
that brings up a thought
will costco replace / refund the new gen that firman sent you direct?
that is if you had issues with the new replacement gen.....
 

·
Registered
Joined
·
3 Posts
I don't know if Costco would know the difference, but I didn't return it to them because I didn't want to dump this on them (I see too many bogus returns at my local Costco), and Firman did send me a replacement unit, BUT dealing with their customer service to have the defective unit shipped back was a royal pain.
 
61 - 80 of 82 Posts
Top