Power Equipment Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have got 3 weed eaters, there all used and need repairs, I got them free so i am trying to repair them, or use parts.

Anyways ECHO srm 230 is the one I see working the best out of them all.

The only problem everytime I try to pull the start cord it stops, can't get it pass half inch.

What I have done:

Took off the pulley cord (this move freely when not on weed eater)
The starter pawl looks fine, but it doesn't turn around it keeps getting locked up, It does allmost a full turn then locks, tryed both ways, and also try to hold tigger and same thing.

Any ideas?
 

·
Premium Member
Joined
·
611 Posts
Pull the piston and inspect the piston,rings,and cylinder the piston or cylinder could be severely worn causing the rings to catch in one of the ports and locking it up (seen it before) another possibility is that there is excess carbon or some foreign object in there and not allowing the piston to move I'm sure there could be something entirely different causing the problem but you won't know till you open it up more.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
So I should open it up and get some carb cleaner and clean everything out.

And take alook to see if piston are worn, if so then I guess I would have to get new pistons...?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
I took it all apart, havn't cleaned anything yet, Just took it apart, it needs I good clean, thinking of rebuilding most fo the engine.

ANYWAYS: The piston is hitting the wall *somehow*, So hopfully when i put it all back togather it will work fine...?
 
1 - 4 of 4 Posts
Top