Power Equipment Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi all, after having problem with my compressor I came across this forum and hope you can help me out?

I have a Fiac Air Compressor which I believe to be an Airforce AF15/150.
On the tank it says Diamond Compressors Professional TH141501

I got the compressor new in October 2010. Recite says TH141501, Professional 3HP 9.9CFM 150L 1 Phase Compressor

The problem I am having is it trips the overload protection switch after around 48sec of use. I wait around 15sec and push the reset button and it runs again for around 48sec.
The motor is not getting hot and this happens in all-weather temperatures.

Hope this info can help you to help me?

Cheers

Ian
 

·
Registered
Joined
·
3 Posts
Discussion Starter #2
Pic of Overload switch



Pic of pump and motor


Pic of motor info plate


Pic of some thing inside the switch housing. Dont know if its relivant
 

·
Premium Member
Joined
·
347 Posts
Take the info off the switch and try replacing it with a new one.

They can become weak sometimes

If you own an amp meter see what the amp draw on the motor is too, make sure its not over the 16 of the cut off switch

If it is, then it can be a sign you need a new motor for the pump
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
Thanks for the reply guys. Motor as been off and tested, was ok.
Capacitor was low on the readings, as now been replaced along with trip switch and now running ok. Total bill was £15.00

Result.

Ian
 
1 - 7 of 7 Posts
Top