Power Equipment Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have 2 (yes 2) Champion 5500W Model: 100340 generators, Bought them prior to Hurricane Harvey, i started both of them the day i got them, they both ran perfect.

1 was kept in storage, i did keep the oil inside, it has since been replaced, Now i cannot, get this generator to even turn over at all. I have purged and replaced oil, the small small amount of gas that i did find left inside (it had been in storage since 2016). replaced the spark plug, completely rebuilt the carb and cleaned it, checked all the wiring for corrosion or tears, the whole thing is almost spotless and zero rust. I did get it to "sort of start" when i sprayed carb cleaner into the carb prior to taking it apart but it just came to life then died, without the spray it wouldnt even turn over.

My second generator, which is where my astonishment comes into play, still has the olddddd gas inside of it, and oil, and starts, perfectly,

any pointers or something i am missing?
 

·
Registered
Joined
·
706 Posts
so does it still try to start on carb cleaner or a hint of gasoline???
if so then;

drop the carb bowl off and see if you are getting fuel.

some of these gens have screens in the fuel tank, or inline fuel filters from the tank to the carb.

so how far did you go on your carb clean??
did you clean the idle jet as well as the idle air jet??

did you ultrasonic clean it?? this works best on modern gen carbs!

was the fuel ethanol fuel?

most long term sitting equipment carbs with ethanol get trashed... and need replaced..

report back what is up.
 
1 - 2 of 2 Posts
Top