Power Equipment Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Got a free compressor from work.
First day worked after fixing a wire without an issue used it for a few things.
2 weeks later I drained tank cause I know it was negelected to make sure it wasn't full of water And replaced o ring.the tank fills up between 60-100psi then internal breaker has to be reset.
I pulled tank pressure leading into tank and spring was broken on one of the ends.
I reassembled it but still same issue occured.
Occasionally I have to play with contact plate of pressure switch for regulator with the breaker to get it running again.
Pressure switch sticks open and on and off leaver won't function until I push it back down manually then reset breaker
 

·
Registered
Joined
·
150 Posts
Zachary,

Have a few questions:
1. list the brand name and/or model number of compressor?
2. HP size of electric motor?
3. Pump type E.G. Devilbis, Champian, Dayton, etc ?
4. a few pictures might help
5. clarification of WTF "I pulled tank pressure leading into tank and spring was broken on one of the ends" means

Stephen
 

·
Registered
Joined
·
150 Posts
amps

Zachary,

The fix depends on how much you have to spend $ (replace motor or compressor) How much you use or need this compressor, how much time you have to fix it and if you are mechanically inclined. Diagnostic skills come in handy if your cheap or broke and sometimes they are unavoidable (hiring a Professional)

With a clamp on ameter (Harbor Freight $15) How many amps is the motor pulling? within FLA listed on the motor? someone installed too small a motor or too big a drive pulley?

Could be a bad winding or run capacitor as a guess. Only testing running amps and possibly testing the run capacitor will tell. There could also be too much mechanical resistance (belt too tight, a bad bearing in the motor or pump).

Stephen

Got a free compressor from work.
First day worked after fixing a wire without an issue used it for a few things.
2 weeks later I drained tank cause I know it was negelected to make sure it wasn't full of water And replaced o ring.the tank fills up between 60-100psi then internal breaker has to be reset.
I pulled tank pressure leading into tank and spring was broken on one of the ends.
I reassembled it but still same issue occured.
Occasionally I have to play with contact plate of pressure switch for regulator with the breaker to get it running again.
Pressure switch sticks open and on and off leaver won't function until I push it back down manually then reset breaker
 
1 - 3 of 3 Posts
Top