MWM generator fault - Power Equipment Forum : Power Equipment Forums
User Tag List

 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 02-11-2020, 12:34 AM Thread Starter
Junior Member
 
Join Date: Feb 2020
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Post MWM generator fault

Hi all,

We are facing a fault with our gas generator TCG2020v12 by MWM. The fault on our TEM screen says "G143 protection of TEM genset cabinet". So far, I couldn't find the reason that triggers it.

Let me know if anyone out here know about this fault.

Thanks
zohair.hassan is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 02-11-2020, 02:02 AM
Senior Member
 
tabora's Avatar
 
Join Date: Sep 2018
Location: Cape Elizabeth, Maine
Posts: 381
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 75 Post(s)
I believe that refers to a Circuit Breaker fault in the TEM cabinet? There are a few models in that group. Is yours 50 or 60Hz? Does the model number have a K or K1 or (1.0) suffix?
tabora is online now  
post #3 of 5 (permalink) Old 02-11-2020, 01:43 PM
Member
 
Join Date: Dec 2019
Location: West Boston suburb
Posts: 98
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
I, too, see that reference, pg 23?
This is a large commercial installation, I assume, with options. They should be using the as-delivered SD's and CD's.

Last edited by Melson; 02-11-2020 at 06:07 PM.
Melson is online now  
Sponsored Links
Advertisement
 
post #4 of 5 (permalink) Old 02-11-2020, 06:13 PM Thread Starter
Junior Member
 
Join Date: Feb 2020
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Hi Tabora,

Our model is 50hz. We do have a number of K suffix but not sure which one to go for. Our operator at site has checked all the circuit breakers and they are working. Another thing about the fault, it appears on its own randomly. Sometimes we can acknowledge it, sometimes we can't.

Melson, what is this page "23" youre referring to?
zohair.hassan is offline  
post #5 of 5 (permalink) Old 02-12-2020, 03:35 PM
Member
 
Join Date: Dec 2019
Location: West Boston suburb
Posts: 98
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 21 Post(s)
Quote:
Originally Posted by zohair.hassan View Post
Melson, what is this page "23" youre referring to?
Don't you have documentation?
Melson is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Power Equipment Forum : Power Equipment Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome