Please help me troubleshoot my Echo PE 2000 trimmer fuel issue. - Power Equipment Forum : Power Equipment Forums
User Tag List

 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 08-16-2012, 07:58 PM Thread Starter
jow
Senior Member
 
Join Date: Aug 2012
Posts: 123
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Please help me troubleshoot my Echo PE 2000 trimmer fuel issue.

Please help me troubleshoot my Echo PE 2000 trimmer fuel issue.


1. I finally got the trimmer to run good above idling only (initially), used it, and stored it about a month with fresh SaBil treated 50:1 fuel.

2. The trimmer w/n not run constantly again w/o it appearing as running out of gas (with air in fuel vs solid fuel in the carb to tank return fuel line).

3. A disassembly and study of two types of primer bulbs plates/bodies took place (since I c/n draw and push solid fluid w/o air in the original). I learned one had a noticeable "Duck-Bill" one-way valve and good. The suspicious valve in use was under a welch plug that Iíll check later.

4. The bulb with the noticeable Duck-Bill showed a good improvement and better when I added an O-ring under the retainer to help seal it tighter.

5. Primed It And It Ran Continuously! Wide Open Throttle (WOT) Or At Idle, fine tuning will comelater. I Wish I Could Remember How Many Years Old This Project Is (4 Maybe vs Hours). LOL!

6. Solving the air in the fuel was the Key. Seeing the primer sys was pulling air w/o the plastic valve/gasket below the bulb helping to control the air in the bulb was the big break. Until this study I felt the plastic valves contributed to the air. This will add another Page to my notes.

Please add additional info, links or Pics that might help to verify what I feel I learned. I just joined this Board to try and get some help on this matter. Now, I hope this info is worth sharing

Last edited by jow; 04-15-2014 at 10:11 PM.
jow is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Power Equipment Forum : Power Equipment Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome