Honda G400 10hp. CDI pack failure, cannot find parts. Looking for alternative / hack - Power Equipment Forum : Power Equipment Forums
User Tag List

 2Likes
  • 1 Post By sostahoe
  • 1 Post By sonicbob
 
LinkBack Thread Tools
post #1 of 2 (permalink) Old 07-23-2018, 02:55 PM Thread Starter
Junior Member
 
Join Date: Jul 2018
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Honda G400 10hp. CDI pack failure, cannot find parts. Looking for alternative / hack

I HAD a reliable g400 motor on my pressure washer. It failed while in service. Was found too have no spark, and appears to have a CDI pack failure.* I have done a bunch of serches and research , but was unable to find a replacement. (Exempt one for $175.00 used in rough shape)
Has anyone been able to retrofit an alternative CDI from another motor ?* Any ideas or resource link would be very appreciated.

Sent from my SM-P905V using Tapatalk
robertstaley28 likes this.
sostahoe is online now  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 08-05-2018, 11:02 PM
Junior Member
 
Join Date: Jul 2018
Posts: 14
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Would you care to post the Model # and the Serial # ?
robertstaley28 likes this.
sonicbob is online now  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Power Equipment Forum : Power Equipment Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome