8kw Generac rough idle - Power Equipment Forum : Power Equipment Forums
User Tag List

 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 10-02-2016, 06:35 PM Thread Starter
Junior Member
 
Join Date: Oct 2016
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
8kw Generac rough idle

My 8kw natural gas Generac residential standby generator has started to idle rough. Did some troubleshooting today and what I found is that once I open the air filter cover cap and then shut it - the generator immediately runs great and continues till I shut the generator off, then on start up it idles rough until I do the open and close on the filter cover cap. I have done this with the filter installed and removed. Still same results. Filter looks brand new. Spark plug is brand new. Thoughts on what I should be looking at to repair?
Jesterbreeze is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-03-2016, 12:00 AM
Junior Member
 
Join Date: Jul 2015
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Try replacing the air filter or removing it, then starting the unit. Generac had a bad batch of filters a while back with too much fire retardant on them causing it to choke off the engine air supply a little, therefore making the engine hunt a bit or run sloppy.
Dan N. is offline  
post #3 of 3 (permalink) Old 10-03-2016, 06:17 PM Thread Starter
Junior Member
 
Join Date: Oct 2016
Posts: 2
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks Dan - I did try that and the generator does the same thing whether the air filter is installed or not. It just takes opening the air filter cover cap and then shutting and the generator will run fine until you shut it down and then start again. I have read somewhere about some baffles in that housing that the air filter goes into, but unsure if the 8kw has those baffles.
Jesterbreeze is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Power Equipment Forum : Power Equipment Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome